Synapsenschredder

Code, Work, Income.

Ubuntu 16.04 LTS auf einem Lenovo ThinkPad 460s

Ubuntu 16.04 LTS auf einem Lenovo ThinkPad 460s

Im Rahmen eines neuen Jobs wurde ich dankenswerterweise mit einem tollen Lenovo ThinkPad 460s ausgestattet, dass ich mir nach belieben einrichten durfte.

Als Software-Entwickler habe ich bisher immer unter Windows gearbeitet. Zum einen aus Gewohnheit oder weil die IT-Abteilungen früherer Arbeitgeber keine ausreichenden Linux-Administratoren hatten und sich hauptsächlich auf die Einrichtung von Windows-Systemen spezialisiert haben. Erst bei meinem letzten Job war es aber nun so, dass in der gesamten IT-Abteilung Linux das am meisten genutzte System war und das war auch das erste Mal, dass ich zu 100% unter Linux mit einer Ubuntu-Installation gearbeitet habe.

Da ich mittlerweile auch so gut wie keine Anwendungen mehr benötige, die es nur unter Windows gibt, viel mir dieser Umstieg auch nicht so schwer. Wenn man nicht zu sehr in die "Eingeweiden" des Betriebssystems einsteigen muss, wie z.B. komplizierte Netzwerk-Konfigurationen etc., findet man sich sehr schnell auch unter Ubuntu zurecht. Zumal ich ja auch schon etwas fortgeschrittenere Kenntnisse in Linux aufweisen kann, weil ich früher viele Entwicklungs- oder auch Live-Server mit Linux betrieben habe, aber eben hauptsächlich über die Konsole und keine grafischen Benutzeroberflächen. Außerdem zeichnete sich ab, dass ich bei meiner neuen Tätigkeit Anwendungen wie Vagrant oder Docker nutzen muss, weil unterschiedliche Webseiten betreut werden sollen, die alle unterschiedliche Versionen von PHP, MySQL usw. nutzen. Also entschied ich mich für meinen neuen Job, auch hier komplett Linux/Ubuntu zu nutzen. Zumal damit auch keine lästigen Lizenzgebühren fällig werden usw.

Installation

Zunächst habe ich mir auf meinem privaten Windows-Rechner nach den Anweisungen der offiziellen Seite Ubuntu 16.04 auf einem USB-Stick installiert. Nachdem dies erfolgt ist, habe ich über das Bios des neuen Notebooks die Boot-Reihenfolge so eingestellt, dass das erste Boot-Device ein USB-Stick sein soll. USB-Stick mit Ubuntu eingesteckt, Notebook neu gestartet, Ubuntu wurde geladen und die Installation konnte los gehen.

Probleme - natürlich

Leider tauchten gleich diverse Probleme auf. Zum einen wollte ich Ubuntu gleich mit einer Verschlüsselung installieren. Prompt funktionierte dies nicht, weil die Installation direkt beim Schreiben des Grub Bootmanagers fehl schlug und ich somit dann plötzlich ein Notebook hatte, auf dem zwar nun Ubuntu drauf war, aber nicht booten konnte. :( Big Fail. Ein zweiter Versuch brach dann noch viel früher mit anderen Fehlermeldungen ab.

Dank des Ubuntu-Systems auf dem USB-Stick konnte ich durch diverse Fehlerlogs herausfinden, dass durch die Verschlüsselung und dem Abbruch der ersten Installation das Dateisystem nun verschlüsselt war, aber die zweite Installation eben deswegen nicht mehr die alten Daten überschrieben konnte. Also nächster Versuch.

Von da an habe ich dann erstmal auf die Verschlüsselung verzichtet und versucht, Ubuntu überhaupt mal lauf- und bootfähig zu installieren. Nach diversen Versuchen lief die Installation dann endlich mal ohne Fehler durch, gebootet hat das System dann aber doch nicht. Mööööp. :(

Nach vielen hin und her und Recherchen hatte ich endlich den richtigen Schalter gefunden. Im Bios des Notebooks gibt es die "Boot Options". Dort musste "UEFI and Legacy" eingestellt werden, aber mit "UEFI first". Nach dieser Änderung sah das Booten vom USB-Stick auch plötzlich anders aus. Es wurde nicht mehr das Ubuntu-System als solches gestartet, sondern man bekam ein rudimentäres Text-Menü präsentiert, wo man die Auswahl zwischen dem Laden der Ubuntu-Oberfläche oder der Installation hatte. Mit der Installation und einer komplett neu partitionierten Festplatte klappte dann auch endlich das Starten des Ubuntu-Systems direkt von der Festplatte!

Das System konnte auch übers LAN direkt ins Internet, die kabellose Tastur und Maus wurde über den dazugehörigen USB-Adapter ebenfalls sofort erkannt und alles schien zu laufen. Bis ich per HDMI dann den großen Monitor anschließen wollte...

Zweiter Monitor nicht unterstützt?

Denn kaum, dass das HDMI-Kabel im Notebook war, wurde zwar erkannt das ein zweiter Monitor angeschlossen ist und konnte den auch konfigurieren, aber auf dem Monitor selber gab es nur Grafiksalat. Ähnliches kenne ich noch von früher, wenn man z.B. einen Monitor mit einer höheren Bildwiederholfrequenz betreiben wollte, als er eigentlich kann.

Zum Glück war das nur ein Problem bei meinem privaten und schon etwas älteren Monitor und/oder dem dazugehörigen HDMI-Kabel. Am eigentlichen Arbeitsplatz mit einem aktuellen Monitor und Kabel funktionierte alles auf Anhieb. Und das bei der vollen Auflösung von 2560x1440 Pixeln! Yeah!

Fazit

Zu dumm, dass die Installation selber so problematisch war, das hat mich doch einige unnütze Stunden Zeit gekostet. Seitdem das System aber installiert ist und läuft, habe ich in der täglichen Arbeit bis jetzt keine größeren Probleme feststellen können und das Notebook kommt auch bei zwei Displays mit 2560x1440 Pixeln kaum ins Stocken. Lediglich manche Animationen der Gnome3 Oberfläche sind nicht ganz flüssig, was jetzt aber auch nicht so schlimm ist. Für die normale Arbeit als Entwickler reicht das alles locker aus und zum Glück kann man diese Animationen auch komplett abschalten. Jetzt stockt da nichts mehr.